Projects/Owasp Esapi Ruby/Releases/Owasp Esapi Ruby v0.30.0

From OWASP
Revision as of 12:07, 7 August 2011 by Paulo Coimbra (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

back to project home page

what is this release?
Owasp Esapi Ruby v0.30.0 - March 2011 - (download)
Release Description:
  • The OWASP Esapi Ruby gem will require at least version 1.9.2 of Ruby interpreter to make sure to have full advantages of the newer language APIs. In particular version 1.9.2 introduces radical changes in the following areas:
    • Regular expression engine (to be written)
    • UTF-8 support
    • Unicode support in 1.9.2 is much better and provides better support for character set encoding/decoding
      • All strings have an additional chunk of info attached: Encoding
      • String#size takes encoding into account – returns the encoded character count
      • You can get the raw datasize
      • Indexed access is by encoded data – characters, not bytes
      • You can change encoding by force but it doesn’t convert the data
    • Dates and Time
      • From “Programming Ruby 1.9“
      • “As of Ruby 1.9.2, the range of dates that can be represented is no longer limited by the under- lying operating system’s time representation (so there’s no year 2038 problem). As a result, the year passed to the methods gm, local, new, mktime, and utc must now include the century—a year of 90 now represents 90 and not 1990.“
Release License: BSD license
who worked on this release?
Release Leader(s):
how can you learn more?
Release Notes: View
Release Rating: Yellow button.JPG Not Reviewed - Assessment Details
Key Contacts
  • Contact the GPC to report a problem or concern about this release info or to update information.