PHP File Inclusion

From OWASP
Revision as of 12:11, 3 October 2007 by Kaf (Talk | contribs)

Jump to: navigation, search

This is a Vulnerability. To view all vulnerabilities, please see the Vulnerability Category page.


Description

PHP as many other languages allow the inclution of files in order to provide or extend the functionality of the current file.

Examples

<?PHP include '/path/filename.php'; include_once 'path/filename.class.php'; require '../path/filename.inc'; require_once 'filename.inc.php'; ?>

Related Threats

Related Attacks

Related Vulnerabilities

Related Countermeasures

Categories

This article is a stub. You can help OWASP by expanding it or discussing it on its Talk page.