Category:OWASP Vicnum Project

Revision as of 11:44, 27 August 2009 by Paulo Coimbra (Talk | contribs)

Jump to: navigation, search



OWASP Vicnum Project

OWASP Vicnum Project is a collection of intentionally vulnerable web applications and will now includes an intentionally vulnerable web API


“Flexible, realistic, vulnerable web applications useful to auditor’s honing their web application security skills”

They demonstrate common web application vulnerabilities such as SQL injection and cross site scripting. They can also be used to test non technical vulnerabilities.

Vicnum applications are commonly used in Capture the Flag exercises at security conferences.


Project Goal

Have fun and stimulate interest in the field

Test web application scanners

Test manual attack techniques

Test source code analysis tools

Look at the code that allows the vulnerabilities

Test web application firewalls

Examine evidence left by attacks

Learn how to test API's

Where is Vicnum?

Vulnerable VM of some Vicnum applications are downloadable from sourceforge. (see )

Since individual applications within the project are constantly being updated, not everything is on that VM. Individual components are either on sourceforge or on github. ( The latest release update (v1.7) was a basic ctf (

Vicnum applications are also distributed as part of the Broken Web Application Project (see

Vicnum applications are also typically available online at and


Project Leader

Mordecai Kraushar

Nicole Becher

Related Projects



OWASP Vicnum is free to use. It is licensed under the Creative Commons Attribution-ShareAlike 3.0 license], so you can copy, distribute and transmit the work, and you can adapt it, and use it commercially, but all provided that you attribute the work and if you alter, transform, or build upon this work, you may distribute the resulting work only under the same or similar license to this one.

Quick Downloads

News and Events

This project is sponsored by CipherTechs.


New projects.png Owasp-builders-small.png
Project Type Files CODE.jpg

Q1 Anything I need to set up vicnum?
There is a help folder in the download and a pdf manual. Basically set up the database, make sure the apache modules are loaded and modify the http config file to find the perl code in the cgi-bin folder.
Q2 Is there a way to make the challenges harder or easier?
Sure. Some suggestions are in the help file, one of them of course is to delete the help file. You can also modify the backdoors, allow indexing of folders, or change the encoding of hidden fields.
Q3 Is there more to it than just technical challenges?
Absolutely. In hacking a web application looking at the nature of the app or examining the so-called business logic is always a good idea. So looking for the back doors and hidden files is definitely a goal here.


Vicnum is developed by a worldwide team of volunteers. The primary contributors to date have been:

  • Nicole Becher
  • Mordecai Kraushar


Vicnum has been demonstrated at many chapter events, many attendees have provided feedback afterwards. In particular a big shout out to Daniel Zabib and Albert Fong who helped customize Vicnum applications for the APPSECUSA conference.

The Vicnum Project is affiliated with the Brooklyn OWASP chapter.

The vulnerable API !

API’s are everywhere! Mobile & web applications applications, cloud services, the Internet of Things and embedded devices are all communicating via API’s.  A vulnerable API can be just as destructive as a vulnerable web application.  So, how do you test an API?   The vulnerable API has a number of serious issues including many of the classic OWASP Top 10 vulnerabilities.  This release is meant for pen testers, breakers and developers and will demonstrate some of the common flaws that are found in API’s such as: Authentication



Transport Encryption Denial of Service

Insecure Direct Object References

Unrestricted File Uploads

Involvement in the development and promotion of Vicnum is actively encouraged! You do not have to be a security expert in order to contribute. Some of the ways you can help:

  • Coming up with a name (and maybe themes for a vulnerable API program)

Vicnum was introduced in 2009 as new CTFs have been introduced releases have changed. Recent release upgrades are:

V1.5 (December 2013) Cyclone, a vulnerable Ruby on Rails Application

V1.6 (June 2014) Breaking Bad XXE Exploit

V1.7 (December 2015) Basic CTF to parse a pcap

V2.0 will be introduced in May 2016 and will include an intentionally vulnerable API.

Project Identification

What does this OWASP project offer you?
What does this OWASP project release offer you?
what is this project?
OWASP Vicnum Project

Purpose: N/A

License: N/A

who is working on this project?
Project Leader: N/A

Project Maintainer:

Project Contributor(s): N/A

how can you learn more?
Project Pamphlet: N/A

3x slide Project Presentation: N/A

Mailing list: N/A

Project Roadmap: N/A

Main links: N/A

Project Health: Yellow button.JPG Not Reviewed (Provisional)
To be reviewed under Assessment Criteria v2.0

Key Contacts
  • Contact the GPC to contribute, review or sponsor this project
  • Contact the GPC to report a problem or concern about this project or to update information.
current release
First Release - Unknown Date - (no download available)

Release Leader: N/A

Release details: N/A :

Rating: Yellow button.JPG Not Reviewed
To be reviewed under Assessment Criteria v2.0

Project's License:

This category currently contains no pages or media.